The Official Website of AgoraCart and Agora.cgi Demos Download AgoraCart User Manuals & Wiki Gold Members Forum Go Gold Now! Gold Version Memberships

Payment Gateways
Send a Donation
Founders Club
BLOG: News & Updates

Showcases & Demos

AgoraCart Demos
Shop Live Stores

Downloads & Add-ons

Gold Version Downloads
DBwizz Database Mgr. Store

Help & Support

User Manuals
Gold Version Users Forum
Gold Version Chat
Tech Support
Certified Agora Pros
Certified Designers
Hire a Freelancer

Gold Version Members

Member Benefits
Join Today!
Gold Members Home
Gold Version Users Forum
Gold Version Chat Rooms
Gold Version Downloads

For Store Owners

Merchant Accounts
Cool Resources
Advertise Here
"Powered by" Logos
Web Hosting Search


Contact Us
MEET's Talking Guide
The Ancient Greek Agora

AgoraCart Free User Forums

This is the official FAQ and Cool Tips guide For the AgoraCart shopping Cart software

Official Sponsors of the AgoraCart Project:


RegisterSearchFAQLog in
Reply to topic Page 1 of 1
Wacky gateway problem
Author Message
Reply with quote
Post Wacky gateway problem 
So I've configured the cart and the gateway and everything seems to be in order *ahem* *cough-cough*..

Myself, and a lot of other people are making successful transactions but then some people can't - like 1/5. When they go to checkout it say 'no items in your cart'.

I've tested the system on Win Xp, 2000, 98 and OS X under IE, Opera, Safari and Firefox and I cannot replicate the error. I've checked it at different physical locations too..

My client had the error once also, but later it didn't error. Others have reported the same error consistently..

Anyone have any ideas what could making this thing to trip out for some people??

Please help - I am going eXPLode :shock: rrrRRRR!!!!!!

View user's profile Send private message
Reply with quote
Post RE: Wacky gateway problem 
what does your manager>error log say?
how about your domain error log?
for the ones consistantly experianceing problems you need to know their navigation paths, firewalls, isp (aol by any chance?).
who is your hosting company?
what cutomizations have you done to the core code?
do any of your product names, categories or descriptions have illegal characters in them?
there are tons of reasons why this may happen but it is very rare. so either it's your host, your clients or something you did that is in conflict with perl/cgi.


Reply with quote
Hosting comp = ipowerweb
customization = none really, just basic cart
illegal chars = none at all, been through the database 100000 times
error log = empty except for one I made when I first created the store during testing (july)

it seems pretty random - of course - cuz' I don't know why it happens.
the error is between the cart and the gateway as the error happens on clicking 'secure orderform'

I've started sending out questionaires to the people who report the problem asking for os, browser, isp info.. I've tried everything and cant get the error to happen. but theres a bunch of clients who seem to have no problem getting it! *aCk!*

thanks for the help man.. hope to figure this out

View user's profile Send private message
Reply with quote
Post RE: Wacky gateway problem 
try turning your cookies off in your browser then do a check out. if the cart shows no contents then something is broken inside the store. are you sure all files were uploaded in ascii (except for images)? take a look at your gateway html source (download ftp in ascii) and compare to an original. look for missing script or corrupted script such as "&" changed to &

do you have navigation of your site set up so ppl are clicking in and out of the store?

please post a url to your storefront and post which gateway you're using.


Reply with quote
I've run through without cookies and it works fine. Also checked out the store code man and it looks clean (pulling hair out!)

store is at h**p://

gateway is iTransact

the database is a single ascii file, tab-deliminated
I've been through it turbo-times. would the store
work as often as it does if it were an issue with the
dB? It's working for more than 4/5 clients..

View user's profile Send private message
Reply with quote
just a note, first person replied to the questionaire-
using aol

View user's profile Send private message
Reply with quote
AOL is one of the biggest pains on the internet they make surfing and using websites *very* difficult. I would not be surprised if that is the whole problem. The browser may be AOL's browser. I wonder if that same customer would get the same problem if they just opened the internet explorer *without* clicking on any of the AOL stuff to open it.

God Bless!
Bonnie - AgoraCart Moderator

Get a Gold Membership
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger ICQ Number
Reply with quote

anyone using AOL's or Walmart's Browsers will have problems.. but then again they will have problems on a lot of sites. They are actually designed that way... sorta a frustration trick to keep folks in their own realms of influence. so we might want to start looking at detecting such browsers or making a note if theya re having probs that they can download Exploder, Netscape, Mozilla, or Opera which all work fine.

AOL users will also never be able to log into the store managers.

Mister Ed

Vote Mister Ed for Prez 2012, for a REAL change.

Need Low Cost Startup Option? Try NiftyPay's Pay to Play
View user's profile Send private message Visit poster's website
Reply with quote
well, unfortunately the reports have been equally AOL and people using IE 6 .. so I really don't know what to think.


Next step in ironing this out is to hire a comp to go through it and troubleshoot it? Any ideas?

cost, etc?

View user's profile Send private message
Reply with quote
agoracart does provide a couple of options for you.... there is 1 on 1 mentoring where someone will be assisnged to help you out... as well as tech support for a single issue covering troubleshooting of an install, upgrade, server issue, or code problem.

for more information go to the following link

if you are a member let me know as i'll provide you with a link for member pricing on similar options and a couple others as well....

Best of Luck

Reply with quote
Post RE: Wacky gateway problem 
did you ever get this problem resolved?
i went to your site but couldn't find a store link. :-(

Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum